Project

General

Profile

Unable to download to ESP32-S2-Kaluga-1 V1.3

Added by Jeff Westbrook 9 months ago

There are a couple interesting errors in the attached Pin_Control_20201112_12905.txt file. The first time I tried to download the model, I was using port 6. That failed, so I tried port 7. At that point, it looked like it connected to the ESP32-S2-Kaluga board, but then some interesting errors occured and the process failed.

Can you help, please?

Jeff


Replies (10)

RE: Unable to download to ESP32-S2-Kaluga-1 V1.3 - Added by martin van beek 9 months ago

Hi Jeff,
The output of the dialog windows looks fine.
When the esp flashtool is launched and you see next ascii characters, you should short the GPIO0 to ground for a few seconds.
From that point the binary file will be flashed into your esp32 device.

start: Output of your dialog window:

esptool.py v2.8
Flashing binaries to serial port COM6 (app at offset 0x10000)...
esptool.py v2.8
Serial port COM6
Connecting...
_..
_
..
__..

<<<end: Output of your dialog window:

Success and have fun with your esp32 project, best regards,

Martin.

RE: Unable to download to ESP32-S2-Kaluga-1 V1.3 - Added by Jeff Westbrook 9 months ago

I tried several times to manually make and break the connection from GPIO0 to GND at the appropriate time. However it appears the window of time is not long enough to reliably perform this operation. I was not successful after many attempts. See attached video showing the compile process.

Any ideas?

Jeff

RE: Unable to download to ESP32-S2-Kaluga-1 V1.3 - Added by martin van beek 9 months ago

Hi Jeff,
There is something strange reported about the frequency of the installed crystal, that is much to high and should be 40MHz.
The jumper from GPIO0 to ground is fine, you can see that the flash process is trying to start, you've only 2 line of … and ---.
I've attached my latest dialog file, then you can see what messages should be printed in normal operation.
Best regards,

Martin.

RE: Unable to download to ESP32-S2-Kaluga-1 V1.3 - Added by Jeff Westbrook 9 months ago

I tried running the Kaluga board using the Arduino IDE. It did not give a warning about the crystal frequency, but it did give the same error for the invalid head of packet:

"A fatal error occurred: Invalid head of packet (0x50)"

I then followed this youtube link to update the Arduino IDE with the ESP32-S2 branch: https://www.youtube.com/watch?v=gm1N437ng1Y

I then reran the Arduino program with success - a simple blink program to turn GPIO2 on and off. See attached png file for Arduino programming progress...no errors.

It appears that Waijung2 does not support the ESP32-S2? Would it be possible to update Waijung2 to provide support for the ESP32-S2-Kaluga-1, please? This development kit is very powerful and it would be most useful to be able to use it with Simulink.

Kind regards,

Jeff

RE: Unable to download to ESP32-S2-Kaluga-1 V1.3 - Added by martin van beek 9 months ago

The esp32-S2 is a different chipset, LX7 and missing some interesting interfaces.
But I'm curious how the Time-Of-Flight sensor is implemented, it could be very useful to detect objects.
See for a nice overview of the differences between the esp32 and esp32-s2 next url:

https://maker.pro/esp8266/tutorial/a-comparison-of-the-new-esp32-s2-to-the-esp32

Kind regards,

Martin.

RE: Unable to download to ESP32-S2-Kaluga-1 V1.3 - Added by Krisada Sangpetchsong (เอม) 9 months ago

Hi Jeff and Martin

Thank you so much for sharing your thoughts.

We will look into this but can not confirm a release schedule for this feature (update Waijung2 to provide support for the ESP32-S2-Kaluga-1) at this time.

RE: Unable to download to ESP32-S2-Kaluga-1 V1.3 - Added by martin van beek 8 months ago

Hi Krisada,
Now I'm a bit confused about the compatibility of the Waijung2 blockset.
At this moment it is not clear to me of the ESP32-S2 (LX7 core) is currently supported, or just the standard ESP32 (LX6 core).
To be more practice, can I use next ESP32-S2 board with your Waijung2 blockset:

https://www.gravitech.us/cursdebowise.html

Best regards,

Martin.

RE: Unable to download to ESP32-S2-Kaluga-1 V1.3 - Added by Krisada Sangpetchsong (เอม) 8 months ago

Hi

In theory, we plan for Waijung blockset to support all ESP32 in the family. However, we are acquiring the same hardware to test and comfirm compatibility.

If something is not compatible, it should be fixed in future releases.

RE: Unable to download to ESP32-S2-Kaluga-1 V1.3 - Added by Supachai Vorapojpisut 7 months ago

I have used customized esp-idf for ESP32S2 to build blinking demo for Cucumber board. BTW, you need to fix the incomplete CMakeList.txt to solve the missing header/source file erros.

RE: Unable to download to ESP32-S2-Kaluga-1 V1.3 - Added by Supachai Vorapojpisut 7 months ago

This is my procedure tested with 20.10a version.

1. Create a Simulink model named "blink" for blinking LED
2. Use Build button to generate code
3. Run Visual Studio Code with esp-idf extension
4. Use menu File > Open Folder to open blink_esp32_build_system folder
5. Use F1 > ESP-IDF: Build your project to build -> compilation error
6. Modify main/CMakeLists.txt to add related source files
> set(COMPONENT_SRCS "ert_main.c blink.c waijung2_hwdrvlib.c")
> set(COMPONENT_ADD_INCLUDEDIRS "include")

    (1-10/10)